Grsecurity

Antaŭlonge Dabo Mi parolas pri grsecurity, kerno en kiu multaj sekurecaj mezuroj estas efektivigitaj.

Kio estas grsecurity?

Grsecurity® estas ampleksa sekureco plibonigo por la Linukso-kernon, protektu kontraŭ larĝa gamo de sekureco minacoj tra inteligenta aliro kontrolo, malebligas superfluajn memorojn kaj multajn problemojn, kio igas la sistemon pli fortika, kiu ĝenerale ne bezonas ajnan agordon. Ĝi aktive disvolviĝis kaj konserviĝis dum la lastaj 15 Al?Vin.

Kiel mi instalas ĝin

Debian en ĝia malstabila versio jam havas grsekurecon en siaj deponejoj, oni atendas ke en la sekva stabila versio ĝi venu, Debian-derivitaj distribuaĵoj kiel Ubuntu aŭ Linukso-Mento gastigos ĝin poste.

En la sekva manlibro mi montros al vi kiel instali ĝin debian.

Rememorigu vin antaŭ ol komenci kion koloroj signifas en aplikoj kaj sistemoj

skribita tekstoj en la komandlinio: blua
Eligo en la komandlinio: verde
Dosiero nomoj kaj dosier enhavo: brunaj

Unue mi instalas debian jessie de la netinstila bildo

Post kiam ĝi estas instalita, mi modifas la dosieron /ktp / apt / sources.list kaj mi lasas ĝin kiel sube:

Deb http://ftp.es.debian.org/debian/ sid main
deb-src http://ftp.es.debian.org/debian/ sid main

La reston de linioj mi lasas komentitaj kaj mi ŝanĝas Jessie por sidigi ĝisdatigon de la distribuo.

Mi ĝisdatigas la dissendon per la radiko sekvante la jenajn komandojn:

kapabla-akiri ĝisdatigon
kapabla-akiri dist-ĝisdatigon
kapabla-akiri aŭtoremove
reagordi

Instalo Grsecureco, la kerna versio povas varii por ekscii, kiu el ili mi kuras

apt-cache-serĉo-grsekureco
.......
linux-bildo-4.4.0-1-grsec-amd64 - Linukso 4.4 por 64-bitaj komputiloj, Protekto pri sekureco
.......

Kun ĉi tio mi jam scias, kiu estas la versio, kiun mi bezonas en mia kazo 4.4.0-1

Instalu grsekurecon, anstataŭigu la version per via.

apt-get install linux-grsec-base linux-grsec-source-4.4 linux-grsec-support-4.4.0-1 linux-headers-4.4.0-1-common-grsec linux-headers-4.4.0-1- grsec-amd64 linux-image-4.4.0-1-grsec-amd64

Rekomencu kaj poste por kontroli, ke funkcia grsekureco ni plenumas:

malsama -a
Linuksaj aplikoj kaj sistemoj 4.4.0-1-grsec-amd64 #1 SMP Debian 4.4.6-1 + grsec201603171922 + 1 (2016-03-19 x86_64 GNU / Linukso

Mi esperas ke vi trovos ĝin utila kaj dankas vin pro legado de nia blogo.


About Ignacio Alba Obaya

T?Cnico microinform?Tico kaj formador por la posteno. Amanto de la novaj tecnol?Gias. Administra de GNU/Linukso kaj Vindozo.

Leave al Reply

Your email address will not bo published.