Grsecurity

Cu ceva timp în urmă Dabo Eu vorbesc despre nucleu grsecurity în care sunt puse în aplicare mai multe măsuri de securitate.

Ce este Grsecurity?

Grsecurity® este un accesoriu cuprinzător de securitate pentru kernel Linux, apără împotriva unei game largi de amenințări de securitate prin controlul accesului inteligent, previene desbordamientos en la memoria y una serie de otros problemas haciendo mas robusto el sistema que generalmente no requiere ninguna configuración. Acesta a dezvoltat și menținut în trecut în mod activ 15 ani.

Cum pot instala

Debian în instabilă său a grsecurity în depozitele lor este de așteptat în următoarea versiune stabilă deja veni, Distribuțiile Debian-derivate, cum ar fi Ubuntu sau Linux Mint va primi mai târziu.

I în manualul următor vă voi arăta cum să instalați Debian.

Reamintiți înainte de a începe culorile înseamnă în aplicații și sisteme

texte scrise în linia de comandă: albastru
Ieșire în linia de comandă: Verde
Numele de fișiere și conținutul fișierului: maro

Mai întâi am instalat debian din jessie netinstall imagine

Una vez esta instalado modifico el archivo /etc / apt / sources.list și eu las mai jos:

deb http://Principalele sid ftp.es.debian.org/debian/
deb-src http://Principalele sid ftp.es.debian.org/debian/

Restul liniilor și să le schimbe jessie comentat de sid, în scopul de a actualiza distribuția.

Actualizarea distribuției rulează următoarele comenzi ca root:

apt-get update
apt-get dist-upgrade
apt-get autoremove
repornire

instalați Grsecurity, versiunea de kernel poate varia pentru a afla ce a ta am alerga

apt-cache search grsecurity
.......
linux-image-4.4.0-1-grsec-amd64 - Linux 4.4 pentru PC-uri pe 64 de biți, protecție grsecurity
.......

Cu aceasta și care este versiunea pe care am nevoie în cazul meu 4.4.0-1

grsecurity instalat, înlocuiește versiunea pentru a ta.

apt-get install linux-grsec-base linux-grsec-source-4.4 linux-grsec-suport-4.4.0-1 linux-headers-4.4.0-1-common-grsec linux-headers-4.4.0-1- grsec-amd64 linux-image-4.4.0-1-grsec-amd64

Reporniți și apoi pentru a verifica dacă această operațiune rula grsecurity:

-a uname
aplicacionesysistemas Linux 4.4.0-1-grsec-amd64 #1 Debian Junior 4.4.6-1 + grsec201603171922 + 1 (2016-03-19 x86_64 GNU / Linux

Sper că veți găsi că este util și vă mulțumim pentru lectură blog-ul nostru.


Despre Ignacio Alba Obaya

Microcomputer tehnic și antrenor pentru ocuparea forței de muncă. Iubitor de noi tehnologii. Manager de GNU / Linux și Windows.

Lasă un Răspuns